TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
影響: npm:tinymce >= 8.5.1, < 8.9.3 → 8.9.3, nuget:TinyMCE >= 8.5.1, < 8.9.3 → 8.9.3, composer:tinymce/tinymce >= 8.5.1, < 8.9.3 → 8.9.3, npm:tinymce = 7.9.3 → 7.9.4, nuget:TinyMCE = 7.9.3 → 7.9.4, composer:tinymce/tinymce = 7.9.3 → 7.9.4
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. Workarounds No official workaroun…
| CVE | CVE-2026-116675 |
|---|---|
| 来源 | GitHub Advisory Database |
| 获取时间 | 2026/10/28 06:17 |
| 数据 | Markdown JSON |
2026/10/28 06:07,GitHub Advisory Database 发布了“TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization”(类型:漏洞公告)。严重程度为“高危”(high)。相关技术:JavaScript / Node.js、.NET / C#、PHP。CVE:CVE-2026-116675。