TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
影響: npm:tinymce >= 8.5.1, < 8.9.3 → 8.9.3, nuget:TinyMCE >= 8.5.1, < 8.9.3 → 8.9.3, composer:tinymce/tinymce >= 8.5.1, < 8.9.3 → 8.9.3, npm:tinymce = 7.9.3 → 7.9.4, nuget:TinyMCE = 7.9.3 → 7.9.4, composer:tinymce/tinymce = 7.9.3 → 7.9.4
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. Workarounds No official workaroun…
Read on GitHub Advisory Database
| CVE | CVE-2026-116675 |
|---|---|
| Source | GitHub Advisory Database |
| Fetched | 10/28/2026, 06:17 AM |
| Data | Markdown JSON |
On 10/28/2026, 06:07 AM, GitHub Advisory Database published "TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization" (type: Advisory). Severity is "High" (high). Related technologies: JavaScript / Node.js, .NET / C#, PHP. CVE: CVE-2026-116675.