最新安全信息
第 2 页
6月11日周一
Unbound 1.7.2 released
We are pleased to announce the release of version 1.7.2 of the Unbound recursive DNS resolver. There are a number of bug fixes, but also some features. This release fixes bugs in DNS-over-TLS for windows, and adds the option for Windows users to use the CA certificates from …
5月3日周四
Unbound 1.7.1 released
We are pleased to announce the release of version 1.7.1 of the Unbound recursive DNS resolver. There are a number of bug fixes, but also some features. This release has root key sentinel support, default on, from draft draft-ietf-dnsop-kskroll-sentinel . The root key sentinel helps the root key rollover …
3月15日周四
Unbound 1.7.0 released
We are pleased to announce the release of version 1.7.0 of the Unbound recursive DNS resolver. Apart from numerous big fixes, this version introduces some important new features. Authority zones is an option that makes it possible to transfer an authoritative zone to Unbound. These transfers can happen …
1月30日周二
The peculiar case of NSEC processing using expanded wildcard records
We discovered a vulnerability in the processing of wildcard synthesized NSEC records. The result was Unbound, Google public DNS, PowerDNS and Dnsmasq contained a flaw that made it possible to downgrade secure connections. While synthesis of NSEC records is allowed by RFC 4592 , these synthesized owner names should not be used in the NSEC processing. This does, however, happen in Unbound 1.6.7 and earlier versions. Ralph Dolmans wrote a blog post about the discovery and findings.
1月19日周五
Unbound 1.6.8 released
Unbound 1.6.8 fixes CVE-2017-15105 : vulnerability in the processing of wildcard synthesized NSEC records.
10月10日周二
Unbound 1.6.7 released
Unbound 1.6.7 sets the default for trust anchor signaling to yes. Thismakes a query with the key tags of the validation keys when the trustanchor DNSKEY is retrieved.
9月18日周一
Unbound 1.6.6 released
Unbound 1.6.6 blocks .test and .invalid by default. It has a -p optionto suppress pidfile creation (for startup script integration). And morestats and a shared secret cache for dnscrypt. And bug fixes.
8月21日周一
Unbound 1.6.5 released
Unbound 1.6.5 fixes RFC5011 Trust Anchor tracking for users that install between September 11 and October 11, 2017.
6月27日周二
Unbound 1.6.4 released
Unbound 1.6.4 contains key tag signaling RFC8145 support. B root is renumbered in the default root hints. The dnscrypt code supports the chacha cipher. The Unbound DNSSEC validator supports the ED25519 algorithm. The redirect-bogus patch in contrib can send validation failure users to a landing page.
6月13日周二
Unbound 1.6.3 released
Unbound 1.6.3 fixes an assertion failure when a malformed packet is received with 0x20 enabled.
4月24日周一
Unbound 1.6.2 released
Unbound 1.6.2 has a couple of new features and a list of bug fixes: trustanchor.unbound chaos query, response IP actions, stats from shm, --disable-sha1, dnscrypt support, and edns client subnet support merged in.
2月21日周二
Unbound 1.6.1 released
Unbound 1.6.1 has the 2017 root trust anchor in unbound-anchor. The libunbound API has changed slightly, the callback typedef ends in _type. Source IP rate limiting, log-replies, and the release also has other new features and bug fixes.
12月15日周四
Unbound 1.6.0 released
Unbound 1.6.0 has a number of features and bugfixes. More extensibleEDNS support. Views and local-zone tags provide for more feature rich filtering options, with CNAME support. SSL configuration features to turn on DNS over TLS for particular parts of the namespace. There were some bug fixes as well.
9月27日周二
Unbound 1.5.10 released
In this release there is a fix for long downtime after connectivity loss, which was a longstanding unsolved issue. Features for tcp, TCPFast Open and timeout pressure to close connections when the tcp connections are getting full. Option to use ipv6 /64 for extra entropy. More bug fixes.
6月9日周四
Unbound 1.5.9 released
New IPv6 address for one of the root servers in the default root server configuration. And a number of bug fixes, for CD flags to forwarders, for 0x20 compatibility, for qname-minimisation with DNSSEC.
3月2日周三
Unbound 1.5.8 released
Bug fixes, fix unbound-control-setup lines, fix GOST-hash failures, block .onion leakage.
12月10日周四
Unbound 1.5.7 released
Fix a validation failure, newly added qname minimisation option, and other fixes.
10月20日周二
Unbound 1.5.6 released
Fix occasional segfault in dns64 module and smaller fixes.
10月6日周二
Unbound 1.5.5 released
Algorithm lenience, H root IP, fixes in RFC5011 code and other bug fixes.
7月9日周四
Unbound 1.5.4 released
negative cache options, algorithm lenience option, rate limits and bug fixes.
3月10日周二
Unbound 1.5.3 released
Fix daemon exit after reload, and Solaris portability.
2月19日周四
Unbound 1.5.2 released
Fix validation failure, poison issue with harden-glue off, and add RPZ-style 'inform' local-zone, and control over unix pipes.
12月8日周一
Unbound 1.5.1 released
CVE-2014-8602 denial of service fixed. Crash fix, compile fix. AAAA-filter patch.
11月18日周二
Unbound 1.5.0 released
DNS64, DNSTAP, better random numbers and ub_ctx_add_ta_autr(), num.query.tcpout=value, flush_negative, unblock-lan-zones conf and bug fixes